GFS checkout widget not working on safari browser, iphone and ipad

  • 781 Views
  • Last Post 2 weeks ago
  • Topic Is Solved
Archana posted this 12 December 2018

We have worked on adding gfs checkout widget in our magento checkout page, on desktop chrome browser and other android phones widget is working but we are facing issue on safari browser and iphone, ipad.

Map is not showing at all.

we are getting following javascript errors. please let me know what need to do to fix this issue?

webcomponents.js:1993SyntaxError: Cannot declare a parameter named 'textContent' in strict mode 

Order By: Standard | Newest | Votes
curtnorval posted this 2 weeks ago

I think the problem is with the internet connection when you access the browser. Try checking the internet speed on your device with brasil banda larga.

Archana posted this 21 December 2018

Hello Minas,

Thanks for your reply.

mpachnis posted this 14 December 2018

Hi Archana,

I've tested on iPhone 6 iOS 12.1.1 and working fine, it's slow but I saw the results, have to wait ~30 sec the first time.

Also wokring fine on iPhone 6 iOS 11, iPhone 8 (12.1), iPhone X (12).

Never the less, can you try changing the webcomponents.js in the gfsCheckout.php page with the lite verions (webcomponents-lite.js) and try again, it might crashing this?

 

Regards,

Minas

Archana posted this 14 December 2018

Sorry i forgot to send htaccess username password.

Please use following username and password

admin/admin_123!

mpachnis posted this 14 December 2018

Can't access the page, asks for username & pass. If I cancel the login I'm getting 401.

 

Thanks,
Minas

Archana posted this 14 December 2018

https://staging6.netpetshop.co.uk/gfscheckout.php
this is our demo link, this is not working on iphone.

mpachnis posted this 14 December 2018

The only device that it's not working for you is an iPhone 6 with iOS 12.1, can u share a demo?

I'm not aware of anything that can check for webcomponents compatibilty.

 

Regards,

Minas 

Archana posted this 14 December 2018

When we tested on iphone6 with ios 12.1 its didn't worked.

if there is a check to do in JavaScript to check if it would be supported so we can add a runtime check.

mpachnis posted this 13 December 2018

Hi Archana,

 

We've tested on iPhone6 with iOS 12 and iPhone 8 with iOS 12.1 and works. So iOS 12.1 is supported on the version that widgets depends on.

 

Regards,

Minas

Archana posted this 13 December 2018

What about iphone?

iphone 6s 

iOS 12.1

mpachnis posted this 13 December 2018

Hi Archana,

The GFS Checkout widgets is build on webcomponents technology. For safari this is supported in 7+. The windows version of Safari is below this minimum requirement and is not supported.

 

Regards,

Minas

Archana posted this 13 December 2018

Testing on Windows 10 safari browser - version 5.1.7

Archana posted this 13 December 2018

Hello Minas,

tried first option, might be installed newer version, but still i am getting same error

SyntaxError: Cannot declare a parameter named 'textContent' in strict mode

 

 

 bower install gfs-checkout-widget -F --save

bower gfs-checkout-widget#*     cached https://github.com/GlobalFreightSolutions/gfs-checkout-widget.git#1.6.1

bower gfs-checkout-widget#*   validate 1.6.1 against https://github.com/GlobalFreightSolutions/gfs-checkout-widget.git#*

bower gfs-checkout-widget#^1.2.0           cached https://github.com/GlobalFreightSolutions/gfs-checkout-widget.git#1.6.1

bower gfs-checkout-widget#^1.2.0         validate 1.6.1 against https://github.com/GlobalFreightSolutions/gfs-checkout-widget.git#^1.2.0

bower                                     no-json No bower.json file to save to, use bower init to create one

 

mpachnis posted this 13 December 2018

Hi Archana,

Here are 3 ways to install/update the elements:

1. Assuming that you already have the elements installed, you can run the "bower install gfs-checkout-widget -F --save", this will force to install the latest available version and avoid all conflicts.

2. You can delete the current bower_components folder and run the "bower install gfs-chekcout-widget --save" to get the latest version and dependencies.

3. Another way is to have a bower.json file that will do the job for you. As you can see in the example below, I have set version 1.3.0 but the "^" will force bower the to get the latest available varsoin 1.x.x.

 

{

  "name": "GFSCheckoutWidgets",

  "dependencies": {

    "polymer": "^1.10.0",

    "gfs-checkout-widget": "^1.3.0"

  },

  "resolutions": {

    "polymer": "^1.10.0"

  }

 

}

 

As far for the bower install 'gitHubLink' I only use this command if I need a specific branch. With option 2, you'll not have elements that are not used anymore.

 

Let me know if you still have any problem installing the elements.

 

Regards,

Minas

Archana posted this 13 December 2018

I have updated the latest version

used following command - 

bower install https://github.com/GlobalFreightSolutions/gfs-checkout-widget

 

bower install --save gfs-checkout-widget

is this correct for updating latest version?

 

following message got when i ran above commends - 

Unable to find a suitable version for gfs-checkout-widget, please choose one by typing one of the numbers below:

    1) gfs-checkout-widget#*

    2) gfs-checkout-widget#^1.2.0 which resolved to 1.5.0 and is required by gfs-droppoint#1.2.1

    3) gfs-checkout-widget#^1.3.0 which resolved to 1.6.1 and is required by gfs-store#1.1.0

 

Prefix the choice with ! to persist it to bower.json

 

? Answer 3

bower gfs-checkout-widget#^1.3.0                 install gfs-checkout-widget#1.6.1

bower mp-calendar#^0.1.8                         install mp-calendar#0.1.8

bower fa-awesome#^2.0.1                          install fa-awesome#2.0.2

bower neon-animation#^1.0.0                      install neon-animation#1.2.5

bower polymer-font-awesome-icons#^4.0.0          install polymer-font-awesome-icons#4.4.0

bower iron-selector#^1.0.0                       install iron-selector#1.5.3

bower web-animations-js#^2.2.0                   install web-animations-js#2.3.1

 

mpachnis posted this 12 December 2018

Hi Archana,

It seesms that you're using an old version of checkout widgets. It's best to update to the latest version (1.6.1).

Can you provide more information about macOS & safari version, iPhone and iPad model and iOS?

 

Reagrds,

Minas

Close